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K-06 (ANSYS) 

Формулировка задачи: 

Дано: E, Iz, F, l. 

Плоская замкнутая рама, с тремя 

врезанными шарнирами. 

E – модуль упругости материала; 

IZ – изгибный момент инерции. 

Найти: Эпюру внутреннего изгибающего 

момента MZ. 

Аналитический расчёт (см. K-06) даёт следующее решение: 
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Рис.1. 

Задача данного примера: при помощи ANSYS Multyphisics получить этот же 

результат  методом конечных элементов. 
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

Меняем чёрный цвет фона на белый следующими действиями: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

В меню оставить только пункты, относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

При построениях полезно видеть номера точек и линий твердотельной 

модели, узлов модели конечноэлементной: 

U_M > PlotCtrls > Numbering > 

Отметить KP, LINE, NODE ; 

Установить Elem на “No numbering”; 

Установить [/NUM] на “Colors & numbers”> OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

Установить «Размер» на «22»> OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

Установить «Размер» на «22»> OK 

Предварительные настройки выполнены, можно приступать к решению задачи. 
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Решение задачи: 

Приравняв E, IZ, F и l к единице, результаты получим в виде чисел, обозначенных на рис. 1. синим цветом. 

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

E=1 > Accept > 

A=1e6 > Accept > 

Iz=1 > Accept > 

F=1 > Accept > 

l=1 > Accept > 

nu=0.3 > Accept > 

> Close 
 

2 

Первая строчка в таблице конечных элементов – плоский балочный тип BEAM3: 

M_M  > Preprocessor 

C_P  > ET,1,BEAM3 >  

Посмотрим таблицу конечных элементов: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Close 
 

3 

Первая строчка в таблице параметров («реальных констант») выбранного типа 

конечного элемента:площадь поперечного сечения = A;момент инерции = Iz; высота 

= l/100. 

C_P > R,1,A,Iz,L/100 >  

Посмотрим таблицу реальных констант: 

M_M > Preprocessor > Real Constants > Add/Edit/Delete > Close 
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№ Действие Результат 

4 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

В окошке EX пишем “E”, в окошке PRXY пишем “nu” 

> OK 

Закрываем окно «Deine Material Model Behavior». 

 

Твердотельное моделирование 

5 

Координаты узлов рамы: 

Определяемся с положением рамы относительно глобальнй декартовой системы 

координат. В шарнире совпадают две точки с одинаковыми координатами, каждая 

принадлежит своей части рамы. 
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№ Действие Результат 
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6 

Ключевые точки – границы участков: A’ 1, H 2 и G’ 3 : 

M_M> Preprocessor> Mоdeling> Create> Keypoints> In Active CS> 

NPT пишем 1 

X,Y,Z пишем - l, l,0 > Apply > 

NPT пишем 2 

X,Y,Z пишем - l,0,0 > Apply > 

NPT пишем 3 

X,Y,Z пишем - l,-l,0 > OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots  

7 

Два участка  –  две линии: 

M_M > Preprocessor > Mоdeling > Create > Lines > Lines > 

Straight Line > 

Левой кнопкой мыши последовательно нажать на ключевые точки: 

1 и 2  

2 и 3  

> OK 

Прорисовываем всё, что есть:  U_M > Plot > Multi-Plots 
 

Левая часть рамы: 
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№ Действие Результат 

8 

Внешняя сосредоточенная  сила: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Keypoints > 

Левой кнопкой мыши нажать на 2 ключевую точку > OK > 

Lab установить “FX” 

VALU пишем –F 

> OK 

Прорисовываем всё, что есть:  U_M > Plot > Multi-Plots 

 

9 

Скрываем линии: 

U_M > Select > Entities >  

Устанавливаем “Lines” и “By Num/Pick” 

> Sele None > Cancel 

Прорисовываем всё, что есть: 

 U_M > Plot > Multi-Plots 

 

10 

Скрываем ключевые точки: 

U_M > Select > Entities >  

Устанавливаем “Lines” и “By Num/Pick” 

> Sele None > Cancel 

Проверяем, действительно ли все ключевые точки скрыты 

U_M > List > Keypoint > Coordinates only 

В появившемся окне читаем: «No keypoint to list». 
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№ Действие Результат 
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11 

Ключевые точки – границы участков: G’’ 4 и D’’ 5 : 

M_M> Preprocessor> Mоdeling> Create> Keypoints> In Active CS> 

NPT пишем 4 

X,Y,Z пишем - l,-  l,0 > Apply > 

NPT пишем 5 

X,Y,Z пишем   l,-  l,0 > OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 

При необходимости используйте кнопку автомассштабирования:  
 

Нижняя часть рамы: 
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№ Действие Результат 

12 

Один участок  –  одна линия: 

M_M > Preprocessor > Mоdeling > Create > Lines > Lines > 

Straight Line > 

Левой кнопкой мыши последовательно нажать на ключевые точки: 

4 и 5  

> OK 

Прорисовываем всё, что есть:  U_M > Plot > Multi-Plots 

 

13 

Скрываем линии: 

U_M > Select > Entities >  

Устанавливаем “Lines” и “By Num/Pick” 

> Sele None > Cancel 

Прорисовываем всё, что есть: 

 U_M > Plot > Multi-Plots 

 

14 

Скрываем ключевые точки: 

U_M > Select > Entities >  

Устанавливаем “Lines” и “By Num/Pick” 

> Sele None > Cancel 

Проверяем, действительно ли все ключевые точки скрыты 

U_M > List > Keypoint > Coordinates only 

В появившемся окне читаем: «No keypoint to list». 
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№ Действие Результат 
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Ключевые точки – границы участков: A’’’ 6, B 7, C 8 и D’’’ 9 : 

M_M> Preprocessor> Mоdeling> Create> Keypoints> In Active CS> 

NPT пишем 6 

X,Y,Z пишем - l, l,0 > Apply > 

NPT пишем 7 

X,Y,Z пишем   l, l,0 > Apply > 

NPT пишем 8 

X,Y,Z пишем   l,0,0 > Apply > 

NPT пишем 9 

X,Y,Z пишем   l,-l,0 > OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

При необходимости используйте кнопку автомассштабирования:  

 

Правая верхняя  часть рамы: 
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№ Действие Результат 

16 

Три участка  –  три линии: 

M_M > Preprocessor > Mоdeling > Create > Lines > Lines > 

Straight Line > 

Левой кнопкой мыши последовательно нажать на ключевые точки: 

6 и 7  

7 и 8  

8 и 9  

> OK 

Прорисовываем всё, что есть:  U_M > Plot > Multi-Plots 

 

17 

Внешняя сосредоточенная  сила: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Keypoints > 

Левой кнопкой мыши нажать на 8 ключевую точку > OK > 

Lab установить “FX” 

VALU пишем F 

> OK 

Прорисовываем всё, что есть:  U_M > Plot > Multi-Plots 
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№ Действие Результат 
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18 

Выделяем всё, что сделано: 

U_M > Select > Everything 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

 

19 

Заделка в точке B для исключения кинематической изменяемости системы: 

M_M > Preprocessor > Loads > Define Loads > Apply >  

Structural > Displacement > On Keypoints > 

Левой кнопкой мыши нажать на 7 ключевую точку 

> OK > 

Lab2 отметить “ALL DOF” 

> OK 

Прорисовываем всё, что есть:  U_M > Plot > Multi-Plots 
 

Все  части рамы: 
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№ Действие Результат 

Конечноэлементная модель 

20 

Указываем материал, реальные константы и тип элементов: 

M_M > Preprocessor > Meshing > Mesh Attributes > All Lines > 

MAT установить “1” 

REAL установить “1” 

TYPE установить “1 BEAM3” 

> OK 

 

21 

Участки без распределённых нагрузок можно бить одним конечным элементом: 

M_M > Preprocessor > Meshing > Size Cntrls > ManualSize > 

Lines > All Lines > 

NDIV пишем 1 

> OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

22 

Указываем, что именно нужно теперь прорисовывать по команде Multi-Plots: 

U_M > PlotCtrls > Multi-Plot Controls… >  

Появляется первое окно Multi-Plotting 

> OK > 

Появляется второе окно Multi-Plotting > 

Оставляем в нём отметки только напротив Nodes и Elements 

> OK 

 

 

23 

Рабиваем линии на элементы: 

M_M > Preprocessor > Meshing > Mesh > Lines > Pick All 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

Бирюзовым цветом изображены балочные элементы. Чёрные точки – 

это их узлы. 
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№ Действие Результат 

24 

Переносим на конечноэлементную модель нагрузки и закрепления с модели 

твердотельной: 

M_M > Loads > Define Loads > Operate > Transfer to FE > All 

Solid Lds 

> OK 

 

25 

Связывание линейных степеней свободы узлов в шарнирах: 

M_M > Preprocessor > Coupling/Ceqn > Coincident Nodes > 

lab установить “UX” 

TOLER оставьте по умолчанию “0.0001” 

> OK 

M_M > Preprocessor > Coupling/Ceqn > Coincident Nodes > 

lab установить “UY” 

TOLER оставьте по умолчанию “0.0001” 

> OK 

Обновляем изображение: 

 U_M > Plot > Multi-Plots 
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№ Действие Результат 

Расчёт 

26 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. 

Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. 

Расчёт окончен. 

 

 

Просмотр результатов расчёта 

27 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 

> OK 
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№ Действие Результат 

28 

Составление эпюры внутреннего изгибающего момента: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “6” 

> Apply >  

“By sequence num”, “SMISC,”, “12” 

> OK > 

> Close 

Закрываем таблицу результатов: 

Close 

    

 

29 

Прорисовка эпюры внутреннего изгибающего момента: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res > 

LabI установить “SMIS6” 

LabJ установить “SMIS12” 

Fact пишем 1 

> OK  

Получаем тот же результат, что и на рис. 1а. (только числа, выделенные синим 

цветом). Значения показывает цветовая шкала. 

Можете рисунок эпюры сделать крупнее: коэффициент Fact установите 2 или 3. 
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№ Действие Результат 

30 

Силовая схема: 

U_M > Plot > Elements 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение 

“For Individual” 

Убираем галочку с “Miscellaneous” 

Surface Load Symbols устанавливаем Pressures 

Show pres and convect as устанавливаем Arrows 

> OK >  

В окне “Applied Boundary Conditions” 

  U установить “Off” 

Rot установить “Off” 

  F установить “Symbol+Value” 

  M установить “Symbol+Value” 

> OK >  

В окне “Reactions”  

NFOR установить “Off” 

NMOM установить “Off” 

RFOR установить “Symbol+Value” 

RMOM установить “Symbol+Value” 

> OK >  

Обновляем изображение: U_M > Plot > Elements 

При необходимости корректируйте масштаб кнопками  или . 

Реактивные силы и моменты в заделке точки B практически равны нулю ( ˜10
-10

 ). 

Так и должно быть в данной задаче: система внешних сил взаимно уравновешена, 

закрепление нужно лишь для того, чтобы механическая система формально не 

являлась механизмом. 
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№ Действие Результат 

31 

Усилия в шарнирах: 

U_M > Plot > Elements 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение 

“For Individual” 

Убираем галочку с “Miscellaneous” 

Surface Load Symbols устанавливаем Pressures 

Show pres and convect as устанавливаем Arrows 

> OK >  

В окне “Applied Boundary Conditions” 

  U установить “Off” 

Rot установить “Off” 

  F установить “Symbol+Value” 

  M установить “Symbol+Value” 

> OK >  

В окне “Reactions”  

NFOR установить “Symbol+Value” 

NMOM установить “Off” 

RFOR установить “Off” 

RMOM установить “Off”  

> OK >  

Обновляем изображение: U_M > Plot > Elements 

При необходимости корректируйте масштаб кнопками  или . 

Мы видим силы, с которыми конечные элементы действуют на свои узлы. То есть, 

силы, противоположные по направлению реакциям в шарнирах, изображённым на 

рис. 1б. Но, поскольку они попарно равны, на общем рисунке это незаметно. 
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№ Действие Результат 

32 

Левая часть рамы: 

Прорисовываем: U_M > Plot > Replot 

Выделяем мышью (левая кнопка) конечные элементы левой части: 

U_M > Select > Entities >  

Устанавливаем “Elements” и “By Num/Pick” 

Селектор на “From Full” 

> OK 

Последовательно кликаем левой кнопкой мыши на оба элемента. 

> OK 

Прорисовываем: U_M > Plot > Replot 

Напоминаю: силы в узлах 1 и 3, которые вы видите (начерчены 

малиновым цветом), равны по модулю и противоположны по 

направлению реакциям в соответствующих шарнирах – точках A’ и 

G’ (рис. 1б.). К сожалению посмотреть можно только так. 

Выделяем всё, что есть: U_M > Select > Everything 
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№ Действие Результат 

33 

Нижняя часть рамы: 

Прорисовываем: U_M > Plot > Replot 

Выделяем мышью (левая кнопка) нужные конечные элементы: 

U_M > Select > Entities >  

Устанавливаем “Elements” и “By Num/Pick” 

Селектор на “From Full” 

> OK 

Последовательно кликаем левой кнопкой мыши на элемент. 

> OK 

Прорисовываем: U_M > Plot > Replot 

Видим силы в узлах 4 и 5 равные по модулю и противоположные 

по направлению реакциям в точках G’’ и D’’ (рис. 1б.). 

Выделяем всё, что есть: U_M > Select > Everything 
 

34 

Верхняя левая часть рамы: 

Прорисовываем: U_M > Plot > Replot 

Выделяем мышью (левая кнопка) нужные конечные элементы: 

U_M > Select > Entities >  

Устанавливаем “Elements” и “By Num/Pick” 

Селектор на “From Full” 

> OK 

Последовательно кликаем на каждый из трёх элементов. 

> OK 

Прорисовываем: U_M > Plot > Replot 

Видим силы в узлах 6 и 9 равные по модулю и противоположные 

по направлению реакциям в точках A’’’ и D’’’ (рис. 1б.). 

Выделяем всё, что есть: U_M > Select > Everything 
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются 

файлы с расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, 

“.mntr”,  “.rst” и ”.stat”. 

Интерес представляют “.db” (файл модели) и “.rst” (файл результатов 

расчёта), остальные файлы промежуточные, их можно удалить. 

 


