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I-04 (ANSYS) 
Формулировка задачи: 

Дано: E=2·10
5
 МПа ; 

F=2 кН ; 

l=1 м ; 

a=5 мм . 

Найти:  IX , IY , σmax. 

Аналитический расчёт (см. I-04) даёт следующие решения: 
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Главные моменты инерции 

поперечного сечения : 

5 4 5 4

X YI 0,35 10 м ; I 0,135 10 м .      

Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

результаты методом конечных элементов. 
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Сечение С: 

http://www.tychina.pro/app/download/7960956893/I-04.pdf
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, потом . 

 

Меняем чёрный цвет фона на белый следующими действиями: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

Оставить в меню пункты, относящиеся только к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

Нумеровать ключевые точки, линии, поверхности узлы и элементы: 

U_M > PlotCtrls > Numbering > 

Отметить KP, LINE, AREA, NODE 

Установить Elem на “Element numbers” 

Установить [/NUM] на “Colors & numbers” > OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls> Font Controls> Legend Font> 

«Размер» устанавливаем «22» 

> OK 

U_M > PlotCtrls> Font Controls> Entity Font> 

«Размер» устанавливаем «22» 

> OK 

Предварительные настройки выполнены, можно приступать к решению задачи.
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Решение задачи: 

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

E=2e11   > Accept > 

nu=0.3   > Accept > 

F=2000   > Accept > 

l=1      > Accept > 

a=0.005  > Accept > 

h=0.100  > Accept > 

b=0.046  > Accept > 

s=0.0045 > Accept > 

t=0.0076 > Accept > 

> Close  

2 

Первая строчка в таблице конечных элементов – трёхмерный балочный BEAM188: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Add 

Element reference number пишем 1 

В левом окошке выбираем “Beam” 

В правом окошке “2 node 188” 

> OK > 

В окошке Element types отметить строчку “1 BEAM188” 

> Options > 

K3 установить “Quadradic Form” 

> OK > 

> Close 
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№ Действие Результат 

3 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

EX пишем “E”, 

PRXY пишем “nu” 

> OK 

Закрываем окно«Deine Material Model Behavior».  

Поперечное сечение 

4 

Схематизируем поперечное сечение: 

Операция необязательная. Геометрические возможности препроцессора ANSYS 

позволяют точно описать поперечное сечение любого стандартного проката. 

Однако времени это занимает много. В данном случае аппроксимируем контур 

швеллера прямоугольниками. К какой погрешности это приведёт увидим, 

сравнивая геометрические характеристики полученной фигуры A, IX и IY с 

результатами аналитического расчёта. 
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№ Действие Результат 

5 

Поверхности поперечного сечения: 

Прямоугольники, аппроксимирующие червертушку: 

M_M  > Preprocessor > Modeling > Create > Areas > Rectangle > 
By Dimensions 

X1, X2 пишем в окошках a и a+b 

Y1, Y2 пишем в окошках h/2 и h/2–t 

> Apply > 

X1, X2 пишем в окошках a и a+s 

Y1, Y2 пишем в окошках h/2 и 0 

> OK 

Отражение четвертушки в половинку: 

M_M  > Preprocessor > Modeling > Reflect > Areas > Pick All > 

В переключателе [ARSYM] выбрать вариант «X-Z plane Y» 

> OK 

Отражение половинки в полную фигуру: 

M_M  > Preprocessor > Modeling > Reflect > Areas > Pick All > 

В переключателе [ARSYM] выбрать вариант «Y-Z plane X» 

> OK 

К поверхностям применяется логическая операция наложения: 

M_M  > Preprocessor > Modeling > Operate > Booleans > 

Overlap > Areas > Pick All  

Накладывающиеся части нескольких поверхностей становятся одной 

поверхностью; соприкасающиеся поверхности склеиваются. 
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№ Действие Результат 

6 

Геометрические характеристики начерченной поверхности: 

M_M > Preprocessor > Modeling > Operate > Calc Geom Items > 

Of Areas > 

Переключатель Selection устанавливаем как “Normal” 

> OK 

Получаем:
C C Cx 0 ; y 0 ; z 0    - координаты центра тяжести; 

THXY 0 ;THYZ 0 ;THZX 0   - углы перехода от глобальной декартовой 

системы координат к системе координат главных центральных осей; 

Центр тяжести находится в начале координат, все углы перехода равны нулю. 

Значит оси глобальной декартовой системы координат и есть главные центральные 

оси нарисованной фигуры. Вводить дополнительную декартову систему координат, 

совпадающую с глобальной, не имеет смысла. 

Сверяемся: 

4
X

50,3449I IXX м10   (расхождение с рис.1. составляет 1,5%); 

4
Y

50,1384I IYY м10   (расхождение с рис.1. составляет 2,5%). 
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№ Действие Результат 

7 

Размер стороны элемента для разбиения: 

M_M  > Preprocessor > Meshing > Size Cntrls > ManualSize > 
Global > Size 

Размер Size пишем большой, например 0.05 

> OK 
 

8 

Разбиваем фигуру на элементы и сохраняем разбиение на диске: 

M_M  > Preprocessor > Sections > Beam > Custom Sections >  

> Write From Areas > Pick all > OK > 

В появившемся окне “Write Section Library File” в поле FILE 

напишите имя файла типа “.SECT”, в котором будет храниться 

разбиение построенной фигуры, например S1 

> OK 

 

9 

Считываем разбиение с диска, как поперечное сечение №1: 

M_M > Preprocessor > Sections > Beam > Custom Sections > 

> Read Sect Mesh > 

[SECTYPE] пишем 1 

Section Name пишем название сечения, например Channels 

[SECREAD] пишем название сохранённого файла S1 

> OK 

Окно Warning, предупреждающее о некорректном расчёте 

положения центра сдвига и жёсткости при короблении, 

закройте. 
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№ Действие Результат 

10 

Прорисовываем сечение Channels: 

M_M > Preprocessor > Sections > Beam > Plot Section 

[Secplot] установить “1 Channels” 

Show section mesh? установить “Yes” 

> OK 

Здесь геометрические характеристики сечения мы видим относительно 

горизонтальной и вертикальной центральной осей. 

 

11 

Сдвиговую жёсткость поперечного сечения Channels устанавливаем очень 

высокую для того, чтобы сдвиговые деформации не вносили вклад в перемещения: 

M_M  > Preprocessor > Sections > Beam > Sect Control> 
Section ID выбираем “1 Channels” 

TXZ пишем 1e6 

TXY пишем 1e6 

> OK 

 

12 

Сечение задано, поверхность, по которой оно задавалось удаляем; больше эта 

поверхность не понадобится: 

U_M > Plot > Area 

M_M > Preprocessor > Modeling > Delete > Area and Below > 

> Pick All 
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№ Действие Результат 

Балка, твердотельное моделирование 

13 

Ключевые точки D→1, C→2, B→3, A→4 и точка 5 в вертикальной плоскости для 

ориентации поперечного сечения: 

 - изометрия;   - автоформат (меню справа). 

Точки, лежащие  на оси стержня проставляем в этой системе координат: 

M_M> Preprocessor> Mоdeling> Create> Keypoints> In Active CS> 

NPT пишем 1 

X,Y,Z пишем 0,0,0    > Apply > 

NPT пишем 2 

X,Y,Z пишем 0,0,l     > Apply > 
NPT пишем 3 

X,Y,Z пишем 0,0,2*l   > Apply > 

NPT пишем 4 

X,Y,Z пишем 0,0,3*l   > OK 

Прорисовываем всё, что есть: 
U_M > Plot > Multi-Plots  

Возвращаемся к глобальной декартовой системе координат: 

U_M > WorkPlane > Change Active CS to > Global Cartesian  

Копируем вверх по вертикали одну из точек оси (например точку №4): 

M_M > Modeling > Copy > Keypoints 

Кликаем на ключевую точку 4 

> OK > 

В окошке DY пишем величину вертикального смещения, 

например l 
> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

14 

Три участка – три линии; протягиваем их по направлению оси z: 

M_M > Preprocessor > Mоdeling > Create > Lines > Lines > 

Straight Line > 

Левой кнопкой мыши последовательно нажать на ключевые точки: 

1 и 2 

2 и 3 

3 и 4 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

 

15 

Опоры: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Displacement > On Keypoints > 

Левой кнопкой мыши нажать на 1 ключевую точку 

> OK > 

Lab2 установить “UX”, ”UY” и ”UZ” 

> Apply > 

Левой кнопкой мыши нажать на 4 ключевую точку 

> OK > 

Lab2 установить “UX” и ”UY” 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

16 

Внешние сосредоточенные силы: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Keypoints > 

Левой кнопкой мыши кликнуть на 2 ключевую точку 

> OK > 

Lab установить “FX” 

VALUE установить “-F” 

> Apply > 

Левой кнопкой мыши кликнуть на 3 ключевую точку 

> OK > 

Lab установить “FY” 

VALUE установить “-F” 

> OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 

 

Конечноэлементная модель 

17 

Указываем материал, тип элементов и номер поперечного сечения: 

M_M > Preprocessor > Meshing > Mesh Attributes > All Lines > 

MAT установить “1” 

TYPE установить “1 BEAM188” 

SECT установить “1 Channels” 

Pick Orientation Keypoint(s) установить “Yes” 

> OK > 

Кликаем мышкой на точку 5 

> OK 
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№ Действие Результат 

18 

Размер элементов: 

По одному балочному конечному элементу на каждый участок: 

M_M > Preprocessor > Meshing > Size Cntrls > ManualSize > 

Lines > All Lines > 

NDIV пишем 1 

> OK 

Обновляем изображение: 
U_M > Plot > Multi-Plots 

При необходимости корректируйте масштаб:   или .  

19 

Скрываем оси глобальной декартовой системы координат: 

U_M> PlotCtrls> Window Controls> Window Options> 

[/Triad] установить “Not Shown” 

> OK 
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20 

Рабиваем линию на элементы: 

M_M > Preprocessor > Meshing > Mesh > Lines > Pick All 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

 - автоформат. 

Видим сразу две модели – твердотельную и конечноэлементную. 

 

21 

Указываем, что именно нужно теперь прорисовывать по команде Multi-Plots: 

U_M > PlotCtrls > Multi-Plot Controls >  

Появляется первое окно Multi-Plotting > 

> OK > 

Появляется второе окно Multi-Plotting > 

Ставим отметки только напротив Nodes и Elements 

> OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

Теперь видим только конечноэлементную модель: чёрные точки с номерами – узлы 

модели (1, 2, 3, 4, 5, 6 и 7), цветные линии – балочные конечные элементы, рядом с 

их центрами тяжести видим номера этих элементов(1, 2 и 3). 
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№ Действие Результат 

22 

Переносим на конечноэлементную модель нагрузки и закрепления с модели 

твердотельной: 

M_M > Loads > Define Loads > Operate > Transfer to FE > All 

Solid Lds > OK 

 

 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

 

Расчёт 

23 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. Расчёт 

окончен. 
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№ Действие Результат 

Просмотр результатов: 

24 

Силовая схема: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение 

“For Individual” 

Убираем галочку с “Miscellaneous” 

Surface Load Symbols устанавливаем Pressures 

Show pres and convect as устанавливаем Arrows 

ESYS устанавливаем в положение“on” 

> OK >  

В окне “Applied Boundary Conditions” 
  U установить “Off” 

Rot установить “Off” 

  F установить “Symbol+Value” 

  M установить “Symbol+Value” 

> OK >  

В окне “Reactions”  
NFOR установить “Off” 

NMOM установить “Off” 

RFOR установить “Symbol+Value” 

RMOM установить “Symbol+Value” 

> OK >  

Обновляем изображение: U_M > Plot > Elements 

В рабочем поле видим следующее: 

- Красным цветом начерчены внешние силы; 

- Малиновым цветом начерчены реактивные силы  

Реакции в заделках совпадают с результатами аналитического расчёта, 

показанными на рис. 1. Минус означает направление вектора против глобальной 

декартовой оси. 

 

Рис. 2. 

Для коррекции изображения используйте 

кнопки на панели справа от рабочего поля: 
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№ Действие Результат 

25 

Определяемся с индексами внутренних изгибающих моментов: 

Ещё раз смотрим на рабочее поле. Над балочными элементами показаны их 

ориентационные узлы, а на них - локальные системы координат. Запоминаем: ось z 

(синяя чёрточка) лежит в вертикальной плоскости, ось y (зелёная чёрточка) – в 

горизонтальной. 

Значит: 

– горизонтальная эпюра внутреннего момента будет Mz (момент вокруг оси z); 

– вертикальная эпюра внутреннего момента будет My (момент вокруг оси y). 

Не совсем понятно, что означают цифры 8, 9 и 10 возле центров тяжести конечных 

элемнтов 1, 2 и 3. Вероятно, это «глюк» ANSYS-а. 
 

26 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 > OK 
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№ Действие Результат 

27 

Составление эпюры внутреннего изгибающего момента Mz (горизонтальная 

эпюра): 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “3” 

> Apply >  

“By sequence num”, “SMISC,”, “16” 

> OK > 

> Close 

Смотрим таблицу результатов: 

M_M > General Postproc > Element Table > Define Table > Close 

        

 

28 

Прорисовка эпюры внутреннего изгибающего момента Mz: 

Только элементы и их узлы (ориентационные узлы не показывать): 

U_M > Plot > Elements 

Вид сверху:  ,  

Эпюра в горизонтальной плоскости: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res > 

LabI установить “SMIS3” 

LabJ установить “SMIS16” 

Fact пишем 1 

> OK  

Изометрия:  и несколько раз   

Получаем почти тот же результат, что и на рис. 1. , разница – не более, чем десятые 

доли процента. 
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29 

Составление эпюры внутреннего изгибающего момента My (вертикальная эпюра): 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “2” 

> Apply >  

“By sequence num”, “SMISC,”, “15” 

> OK > 

> Close 

Смотрим таблицу результатов: 

M_M > General Postproc > Element Table > Define Table > Close 
 

30 

Прорисовка эпюры внутреннего изгибающего момента My: 

Элементы: 

U_M > Plot > Elements 

Вид справа:  ,  

Эпюра в горизонтальной плоскости: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res > 

LabI установить “SMIS2” 

LabJ установить “SMIS15” 

Fact пишем 1 

> OK  

Изометрия:  , далее отрегулируйте вид кнопками              

Получаем почти тот же результат, что и на рис. 1. , разница – не более, чем десятые 

доли процента. 
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31 

Полноразмерная прорисовка конечных элементов: 

Элементы: 

U_M > Plot > Elements 

Прорисовываем их полноразмерно: 

U_M > PlotCtrls > Style > Size and Shape > 

[/ESHAPE] установить галочку “On” 

> OK 

 

32 

Скрываем оси систем координат конечных элементов: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем All Applied BCs 

ESYS устанавливаем в положение“off” 

> OK 

 

33 

Напряжения будем смотреть на недеформированной форме: 

U_M > PlotCtrls > Style > Displacement Scaling > 

DMULT устанавливаем “0.0(off)” 

> OK  
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34 

Осевые напряжения: 

M_M > General Postproc > Plot Results > Contour Plot > 

Element Solu> Element Solution> Stress> X-Component of stress 

> OK 

 

 

 

 

Видим минимальное напряжение (MN) там, где у нас опасное сечение. С другой 

стороны (мы её пока не видим) в этом сечении реализуется такое же по величине 

максимальное напряжение, это видно по верхней красной планке цветовой шкалы. 
 

35 

Открываем опасное поперечное сечение: 

Скрываем два ближних конечных элемента: 

U_M > Select > Entities… > 

В Select Entities установить “Elements” и “By Num/Pick” 

Селектор установить на «Unselect» 

> OK > 

Мышкой кликнуть на левый и средний конечные элементы 

> OK 

Выделить только узлы, принадлежащие оставшемуся конечному элементу: 

U_M > Select > Everything Below > Selected Elements 

Рисуем что выделили: 

U_M > Plot > Replot  

σmin 
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36 

Фронтальный вид: 

 - вид спереди;   - автоформат. 

Наиболее опасные точки поперечного сечения отмечены надписями MN и MX 

6
max 1 58,8 10 Па 58,8 МПа ;    

6
min 2 58,8 10 Па 58,8 МПа .         

Расхождение с результатами аналитического расчёта (рис. 1.) составляет 2%. 

Местоположения точек 1 и 2 совпадают. 
 

37 

Настройка нелинейной цветовой шкалы: 

U_M > PlotCtrls > Style > Contours > Non-niform Contours… 

V1 пишем -1e10 

V2 пишем 0 

V3 пишем 1e10 

> OK 

Растянутая зона поперечного сечения окрасится в красный 

цвет, сжатая - в зелёный. Изменим палитру: голубой и жёлтый. 

U_M > PlotCtrls > Style > Colors > Contour Colors… >  

Contour Number 2 устанавливаем “голубой” 

Contour Number 3 устанавливаем “жёлтый” 

> OK 

Видим нейтральную линию (н.л.), отделяющую растянутые зоны друг от 

друга.Линия проходит через центр тяжести сечения (там прилоден вектор внешнего 

момента) и точку D сечения (рис. 1.). 
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются 

файлы с расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, 

“.mntr”,  “.rst”, ”.stat” и “SECT”. 

Интерес представляют “.db” (файлы модели), “.rst” (файл результатов 

расчёта) и файл “.SECT” (поперечное сечение), остальные файлы 

промежуточные, их можно удалить. 

 

 

 

 


