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B-16 (ANSYS) 

Формулировка задачи: 

Дано: Ферма с жёстким брусом; нагрузка силовая (точки B и E) и термическая 

(стержень  GC охлаждается на Δt). 
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A 80 мм ;

E 2 10 МПа ;

l 400 мм ;

F 20 кН ;

F 1 кН ;

80 C ;
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Аналитический расчёт (см. B-16) даёт следующие решения: 

1 1 2

2
N 8 F F 3 t E A 8649 Н ;

27
              

2 1 2

2
N F F 3 t E A 14053 Н ;

9
             

3 1 2

1
N 5 F 23 F 12 t E A 1702 Н ;

27
                

4 1 2

1
N 5 F 4 F 12 t E A 2702 Н ;

27
                

Av 0,2162 мм;   

Bv 0,1101 мм;   

Сv 0,001407 мм;  

Dv 0,1101 мм;  

Tn 1,19 1,2 .   

Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

решения методом конечных элементов. 
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Найти:   Ni,  σi,  nT, vA, vB, vC, vD. 
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Рис. 1. 
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http://www.tychina.pro/app/download/7945482293/B-16.pdf
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

Меняем чёрный цвет фона на белый: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

Скрываем пункты меню, не относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

При построениях полезно видеть номера узлов и номера конечных 

элементов (один участок – один конечный элемент): 

U_M > PlotCtrls > Numbering > 

Отметить NODE ; 

Установить Elem на “Element numbers”; 

Установить [/NUM] на “Colors&numbers” 

> OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

Установить «Размер» на «22» > OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

Установить «Размер» на «22» > OK 

Предварительные настройки выполнены, можно приступать к решению задачи. 
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Решение задачи: 

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

A=80e-6     > Accept > 

E=2e11      > Accept > 

l=0.4        > Accept > 

al=l         > Accept > 

EBAR=E      > Accept > 

ABAR=1e6    > Accept > 

IzBAR=1e6   > Accept > 

F1=20e3     > Accept > 

F2=1e3      > Accept > 

DeltaT=80   > Accept > 

Alpha=11e-6 > Accept > 

nu=0.3      > Accept > Close 
 

2 

Первая строчка в таблице конечных элементов – плоский балочный BEAM3, вторая 

строчка –плоский фермовый LINK1: 

M_M  > Preprocessor 

C_P  > ET,1,BEAM3 >  

C_P  > ET,2,LINK1 >  

Посмотрим таблицу конечных элементов: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Close 
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№ Действие Результат 

3 

Таблица реальных констант: 

Площадь поперечного сечения, изгибный момент инерции поперечного сечения и 

высота поперечного сечения жёсткого бруса: 

C_P  > R,1,ABAR,IzBAR,l/20 >  

Площадь поперечного сечения  остальных стержней: 

C_P  > R,2,A >  

Посмотрим таблицу реальных констант: 

M_M> Preprocessor > Real Constants > Add/Edit/Delete > Close 
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№ Действие Результат 

4 

Таблица материалов: 

Материал №1 – жёсткий, не расширяющийся при нагреве: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

EX пишем EBAR 

PRXY пишем nu 

> OK 

Материал №2 – упругий, не расширяющийся при нагреве: 

M_M > Preprocessor > Material Props > Material Models >  

> Material > New Model… 

Define Material ID пишем 2 

> OK > 

Structural > Linear > Elastic > Isotropic > 

EX пишем E 

PRXY пишем nu 

> OK 

Материал №2 – упругий, расширяющийся при нагреве: 

M_M > Preprocessor > Material Props > Material Models >  

> Material > New Model… 

Define Material ID пишем 3 

> OK > 

Structural > Linear > Elastic > Isotropic > 

EX пишем E 

PRXY пишем nu 

> OK > 

> Structural > Thermal Expansion > Secant Coefficient > 

Isotropic > 

ALPX пишем Alpha 

> OK 

Закрываем окно «Deine Material Model Behavior». 
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№ Действие Результат 

5 
Координаты точек конструкции: 

Определяемся с координатами точек (узлов фермы). 

 

D ( 3 a , 2 l ,0 )    
B 

① ② 
③ 
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⑤ 

A( 0 , 2 l ,0 )   

H ( 3 a , l ,0 )   
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№ Действие Результат 

Конечноэлементная модель 

6 

Узлы 1, 2, 3, 4, 5, 6, 7 и 8 в точках A, B, C, D, P, S, G и H соответственно: 

M_M> Preprocessor> Mоdeling> Create> Nodes> In Active CS > 

NODE пишем 1  

X,Y,Z пишем 0,-2*l,0 
> Apply > 

NODE пишем 2 

X,Y,Z пишем al,-2*l,0 
> Apply > 

NODE пишем 3 

X,Y,Z пишем 2*al,-2*l,0 
> Apply > 

NODE пишем 4 

X,Y,Z пишем 3*al,-2*l,0 
> Apply > 

NODE пишем 5  

X,Y,Z пишем 0,-l,0 
> Apply > 

NODE пишем 6 

X,Y,Z пишем 2*al,0,0 
> Apply > 

NODE пишем 7 

X,Y,Z пишем 3*al,0,0 
> Apply > 

NODE пишем 8 

X,Y,Z пишем 3*al,-l,0 
> OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 

Справа от рабочего поля нажимаем кнопку Fit . 
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№ Действие Результат 

7 

Конечные элементы – упругие стержни фермы: 

M_M> Preprocessor> Mоdeling> Create> Elements> Elem Attributes> 

[TYPE]установить “2 LINK1” 

[MAT ]установить “2” 

[REAL]установить “2” 

> OK 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Auto Numbered > Thru Nodes 

Левой кнопкой мыши последовательно кликаем узлы 

5 и 1 > OK 

M_M> Preprocessor> Mоdeling> Create> Elements> Elem Attributes> 

[MAT ]установить “3” 

> OK 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Auto Numbered > Thru Nodes 

Левой кнопкой мыши последовательно кликаем узлы 

6 и 3 > OK 

M_M> Preprocessor> Mоdeling> Create> Elements> Elem Attributes> 

[MAT ]установить “2” 

> OK 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Auto Numbered > Thru Nodes 

Левой кнопкой мыши последовательно кликаем узлы 

7 и 8 > Apply > 

8 и 4 > OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 

 

Сравниваем номера конечных элементов с номерами 

участков на рис. 1. Они должны совпадать. 
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№ Действие Результат 

8 

Конечные элементы – отрезки жёсткого бруса: 

M_M> Preprocessor> Mоdeling> Create> Elements> Elem Attributes> 

[TYPE]установить “1 BEAM3” 

[MAT ]установить “1” 

[REAL]установить “1” 

> OK 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Auto Numbered > Thru Nodes 

Левой кнопкой мыши последовательно кликаем узлы 

1 и 2 > Apply > 

2 и 3 > Apply > 

3 и 4 > OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 
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№ Действие Результат 

9 

Проверяем правильность формирования модели: 

Нумеруем элементы по их типу: 

U_M > PlotCtrls > Numbering > 

Установить Elem на “Element type num”; 

> OK 

Нумеруем элементы по номеру их материала: 

U_M > PlotCtrls > Numbering > 

Установить Elem на “Material numbers”; 

> OK 

Нумеруем элементы по номеру набора реальных констант: 

U_M > PlotCtrls > Numbering > 

Установить Elem на “Real const num”; 

> OK 

Возвращаемся к порядковой нумерации элементов: 

U_M > PlotCtrls > Numbering > 

Установить Elem на “Element numbers”; 

> OK 
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№ Действие Результат 

10 

Заделки: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

> Structural > Displacement > On Nodes > 

Левой кнопкой мыши нажать на узлы 5, 6 и 7 

> OK > 

Lab2 установить “UX” и “UY” 

> Apply > 

Левой кнопкой мыши нажать на узлы 1 и 8 

> OK > 

Lab2 установить “UX” 

> OK 

Прорисовываем всё, что есть: 
U_M > Plot > Multi-Plots 

 

11 

Внешняя сила: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

> Structural > Force/Moment > On nodes > 

Левой кнопкой мыши нажимаем на узел 2 

> OK > 

Lab устанавливаем “FY” 

VALUE пишем –F1 

> Apply > 

Левой кнопкой мыши нажимаем на узел 8 

> OK > 

Lab устанавливаем “FY” 

VALUE пишем –F2 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

12 

Температуру (а не нагрев!) прикладываем к узлам: 

20° = температура, при которой собиралась конструкция: 
M_M> Preprocessor> Loads> Define Loads> Settings> 

> Uniform Temp> 

[TUINF] пишем 20 

> OK 

20° = температура, от которой отсчитывается начало температурных деформаций: 
M_M> Preprocessor> Loads> Define Loads> Settings> 

> Reference Temp> 

[TREF] пишем 20 

> OK 

20°-Δt° = температура узлов фермы в финале нагружения: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

> Structural > Temperature > On Nodes > Pick All > 

[BF] устанавливаем “Constant value” 

VAL1 пишем 20-DeltaT 

> OK 
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№ Действие Результат 

13 

Проверка нагрузок:: 

Силовой: 

UM > List > Loads > Forces > On All Nodes  

Термической: 

UM > List > Loads > Body > On All Nodes 

 

 

Расчёт 

14 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. 

Расчёт окончен. 
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№ Действие Результат 

Просмотр результатов 

15 

Деформированная форма конструкции: 

M_M > General Postproc > Plot Results > 

> Deformed Shape > 

KUND установить Def + undeformed 

> OK 

U_M > PlotCtrls > Style > Displacement Scaling > 

DMULT устанавливаем “User specified” 

User specified factor увеличиваем в 

три раза с 277 до 850 

> OK 

Чёным цветом начерчена недеформированная форма фермы, цветными линиями 

– ферма после нагружения (масштаб перемещений выбирается автоматически). 

Деформированная форма похожа на ту, которая была нарисована по результатам 

аналитического расчёта (рис.1.). 
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№ Действие Результат 

16 

Вертикальные перемещения точек жёсткого бруса: 

M_M > General Postproc > List Results > Nodal Solution > 

> Nodal Solution > Y-Component of displacement 

> OK  

Вертикальное перемещение точки A (узла №1) 

UY 0,2162 мм     (отрицательное, то есть вниз); точное совпадение с рис.1. ; 

вертикальное перемещение точки B (узла №2) 

UY 0,1075 мм     (отрицательное, то есть вниз) ; погрешность Δ= 2,4 % ; 

вертикальное перемещение точки C (узла №3) 

UY 0,001298 мм  (положительное, то есть вверх) ; погрешность Δ= 7,7 % ; 

и вертикальное перемещение точки D (узла №4) 

UY 0,1101 мм       (положительное, то есть вверх) точное совпадение с рис.1. 

Чем больше перемещение точки, тем с меньшей относительной погрешностью 

оно определено. 
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№ Действие Результат 

17 

Из всех конечных элементов конструкции выделяем только фермовые: 

Прорисовываем все конечные элементы элементы: 

U_M > Plot > Elements 

Выделяем нужные: 

U_M > Select > Entities >  

Устанавливаем “Elements” и “By Num/Pick” 

Селектор на “From Full” 

> OK 

Кликаем левой кнопкой мыши на упругие стержни – элементы 1, 

2, 3 и 4 

> OK 

Прорисовываем: 

U_M > Plot > Replot 
 

18 

Расчёт внутренних осевых растягивающих сил в фермовых элементах: 

M_M > General Postproc > Element Table > Define Table > Add >  

“By sequence num”, “SMISC,”, “1” 

> OK > 

> Close 

 

 



17 

http://www.tychina.pro 

№ Действие Результат 

19 

Распечатка значений внутренних осевых растягивающиз сил  Ni в конечных 

элементах: 

M_M > General Postproc > List Results > Elem Table Data > 

Отметить мышью строчку SMIS1  

> OK  

 

 

С точностью до сотых долей процента получаем тот же результат, что и на рис. 1: 

1N 8649 Н  ; 

2N 14054 Н  ; 

3N 1701 Н   ; 

4N 2701 Н   . 
  

20 

Расчёт осевых напряжений в фермовых элементах: 

M_M > General Postproc > Element Table > Define Table > Add >  

“By sequence num”, “LS,”, “1” 

> OK > 

> Close 
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№ Действие Результат 

21 

Распечатка значений осевых напряжений σi в конечных элементах: 

M_M > General Postproc > List Results > Elem Table Data > 

Отметить мышью строчку LS1  

> OK  

 

 

 

С точностью до сотых долей процента получаем тот же результат, что и на рис. 1: 

1 108,1 МПа   ; 

2 175,7 МПа   ; 

3 21,27 МПа    ; 

4 33,77 МПа    . 
 

22 

Коэффициент запаса прочности по текучести: 

 

T

T

max 1 2 3 2

max

max , , 175,7 МПа ;

210
n 1,19 .

175,7

    





  

  
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются файлы с 

расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, “.mntr”,  “.rst” и 

”.stat”. 

Интерес представляют “.db” (файл модели) и “.rst” (файл результатов 

расчёта), остальные файлы промежуточные, их можно удалить. 

 

 

 

 

 


