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A-06 (ANSYS) 

Формулировка задачи: 

Дано: Консольный стержень нагружен 

системой осевых сил. 

E – модуль упругости материала; 

A – площадь поперечного сечения. 

Найти: эпюры N , σ , ε , w ; значение U. 

Аналитический расчёт (см. A-06) даёт следующие решения: 
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Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

решения методом конечных элементов. 
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http://www.tychina.pro/app/download/7941610393/H-03.pdf


2 

http://www.tychina.pro 

Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

Меняем чёрный цвет фона на белый: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

Убрать пункты меню, не относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

Нумеровать точки и линии твердотельной модели, узлы модели 

конечноэлементной: 

U_M > PlotCtrls > Numbering > 

Отметить KP, LINE, NODE,  

Установить Elem на “No numbering”, 

Установить [/NUM] на “Colors & numbers” > 

> OK 

Увеличить размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > Установить 

«Размер» на «22» > OK 

U_M > PlotCtrls > Font Controls > Entity Font > Установить 

«Размер» на «22» > OK 

Предварительные настройки выполнены, можно приступать к решению задачи. 
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Решение задачи: 

Приравняв E, A, F и l, к единице, результаты получим в виде чисел, обозначенных на рис. 1. синим цветом.  

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

E=1 > Accept > 

A=1 > Accept > 

Iz=1e6 > Accept > 

F=1 > Accept > 

l=1 > Accept > 

nu=0.3 > Accept > 

Iz – изгибный момент инерции поперечного сечения; 

nu – коэффициент Пуассона для металлов.  

2 

Первая строчка в таблице конечных элементов – плоский балочный тип BEAM3: 

M_M  > Preprocessor 

C_P  > ET,1,BEAM3 >  

 

3 

Первая строчка в таблице реальных констант: площадь  A; момент инерции  Iz; 

высота l/10. 

C_P > R,1,A,Iz,L/10 >  

 

4 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

EX пишем “E”, 

PRXY пишем “nu” 

> OK > Закрываем окно«Deine Material Model Behavior». 
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№ Действие Результат 

Твердотельное моделирование 

5 

Разворот рабочей плоскости: 

Прорисовываем систему координат рабочей плоскости. Сейчас она 

ориентирована по глобальной системе координат: 

U_M > WorkPlane > Display Working Plane 

Поворачиваем рабочую плоскость на 180 градусов вокруг оси 

Y с тем, чтобы её ось X была направлена справа налево: 

U_M > WorkPlane > Offset WP by Increments > 

Шесть раз нажимаем на появившейся панельке кнопку 

, наблюдая, как система координат рабочей 

плоскости с каждым нажатием поворачивается вокруг оси Y 

на тридцать градусов. 

 

6 

Рабочая система координат №11 (ось x направлена влево): 

U_M > WorkPlane > Local Coordinate Systems > Create Local CS 

> At WP Origin > 

KCN пишем 11 

KCS устанавить Cartesian 

> OK 

 

Активная система координат автоматически меняется с глобальной (декартова 

система №0, ось X вправо) на установленную нами (декартова №11, ось X влево). 

Можете заметить, как внизу надпись «csys=0» изменилась на «csys=11». Тем не 

менее, оси глобальной системы координат продолжают отображаться. 

 

 

Ось X рабочей 

плоскости 

Ось X глобальной 

системы координат. 
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№ Действие 
Результат 

7 

Гасим в рабочем поле оси рабочей плоскости и оси глобальной системы координат, 

прорисовываем оси локальной рабочей системы координат №11 (ось x): 

U_M > PlotCtrls > Window Controls > Window Options > 

[/Triad] установить “Not Shown” 

> OK 

U_M > WorkPlane > Display Working Plane 

U_M > PlotCtrls > Symbols > 

[CS] установить в положение “on” 

> OK >  

 

 

 

 

 

 

На рабочем поле остаётся рисунок осей рабочей системы кеоординат и её номер 

«11». 

Оси локальных систем не подписываются, только по цвету можно определить их 

названия: 

X – чёрная ось; 

Y – зелёная ось; 

Z – синяя ось. 

Сейчас в рабочем поле мы видим оси X (влево) и Y (вверх). Ось Z направлена от нас и 

не видна. 
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№ Действие Результат 

8 

Ключевые точки G, D, C и B: 

M_M > Preprocessor > Mоdeling > Create > Keypoints > In 

Active CS > 

NPT пишем 1  

X,Y,Z пишем 0,0,0 > Apply > 

NPT пишем 2 

X,Y,Z пишем l,0,0 > Apply > 

NPT пишем 3 

X,Y,Z пишем 2*l,0,0 > Apply > 

NPT пишем 4 

X,Y,Z пишем 3*l,0,0 > Apply > 

 > OK 

Прорисовываем всё, что есть:  U_M > Plot > Multi-Plots 

Справа от рабочего поля нажимаем кнопку Fit . 

Номер точки 1 сливается с первой цифрой номера системы координат 11, поэтому не 

виден. 

 
 
 
 
 
 
 
 

 

9 

Три участка –  три линии между точками: 

M_M > Preprocessor > Mоdeling > Create > Lines > Lines > 

Straight Line > 

Левой кнопкой мыши последовательно кликаем на точки 

2 и 1 

3 и 2 

4 и 3 

> OK 

 

Ключевые точки 
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№ Действие Результат 

10 

Заделка: 

M_M > Preprocessor > Loads > Define Loads > Apply > Structural 

> Displacement > On Keypoints > 

Левой кнопкой мыши нажать на 1 ключевую точку > OK > 

Lab2 установить “All DOF” 

> OK 

 

11 

К ключевым точкам прикладываем внешние сосредоточенные силы: 

M_M > Preprocessor > Loads > Define Loads > Apply > Structural 

> Force/Moment > On Keypoints > 

Левой кнопкой мыши нажимаем на точку 2 > OK > 

Lab установить “FX” 

VALUE пишем -2*F 

> Apply >  

Левой кнопкой мыши нажимаем на точку 3 > OK > 

Lab установить “FX” 

VALUE пишем -F 

> Apply >  

Левой кнопкой мыши нажимаем на точку 4 > OK > 

Lab установить “FX” 

VALUE пишем F 

> OK 

Прорисовываем всё, что есть:  U_M > Plot > Multi-Plots 
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№ Действие Результат 

Конечноэлементная модель 

12 

Указываем материал, реальные константы и тип элементов, на которые будут 

разбиты линии твердотельной модели: 

M_M > Preprocessor > Meshing > Mesh Attributes > Picked Lines 

> Левой кнопкой мыши нажать последовательно на каждую линию 

L1, L2 и L3 > OK > 

MAT установить “1” 

REAL установить “1” 

TYPE установить “1 BEAM3” 

> OK 

 

13 

Участки без распределённой нагрузки можно бить одним элементом: 

M_M > Preprocessor > Meshing > Size Cntrls > ManualSize > 

Lines > Picked Lines> 

Левой кнопкой мыши последовательно нажать на каждую линию L1, 

L2 и L3 

> OK >  

NDIV пишем 1 

> OK 

Обновляем изображение: U_M > Plot > Multi-Plots 
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14 

Рабиваем линии на элементы: 

M_M > Preprocessor > Meshing > Mesh > Lines > 

Левой кнопкой мыши последовательно нажать на каждую линию L1, 

L2 и L3 

> OK >  

Обновляем изображение: 

U_M > Plot > Elements 

 

 

15 

Переносим на конечноэлементную модель нагрузки и закрепления с модели 

твердотельной: 

M_M > Loads > Define Loads > Operate > Transfer to FE > All 

Solid Lds > OK 

 

Расчёт 

16 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. 

Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. 

Расчёт окончен. 

 

номера узлов 
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№ Действие Результат 

Просмотр результатов 

17 

Силовая схема: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение “For Individual” 

Убираем галочку с “Miscellaneous” 

[/PSF] Show pres and convect as устанавливаем в положение 

“Arrows” 

[CS] установить в положение “off” 

> OK >  

В окне “Applied Boundary Conditions”  U установить “Off” 

                           Rot установить “Off” 

                             F установить “Symbol+Value” 

                             M установить “Symbol+Value” 

> OK >  

В окне “Reactions”    NFOR установить “Off” 

               NMOM установить “Off” 

               RFOR установить “Symbol+Value” 

               RMOM установить “Symbol+Value” 

> OK >  

Обновляем изображение:  U_M > Plot > Elements 

Если рисунок не помещается в рабочее поле, уменьшите его: справа от рабочего поля 

нажимаем кнопку Zoom Out . 

Получаем тот же результат, что и на рис. 1а. 

Красным цветом указаны внешние силы, малиновым цветом – реакция.  
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№ Действие Результат 

18 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 

> OK 

 

19 

Составление эпюры внутренней растягивающей осевой силы: 

M_M > General Postproc > Element Table > Define Table > Add >  

“By sequence num”, “SMISC,”, “1” > Apply >  

“By sequence num”, “SMISC,”, “7” > OK > Close 

 

20 

Прорисовка  эпюры внутренней растягивающей осевой силы: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res >  

LabI установить “SMIS1” 

LabJ установить “SMIS7” 

> OK  

Получаем тот же результат, что и на рис. 1б.  

Видим эпюру, состоящую из двух прямоугольников. Высоту каждого можно 

определить по его цвету: левый прямоугольник высотой -1, правый прямоугольник 

высотой +2. 

Цифры 1…4 есть номера узлов конечноэлементной модели (см. действие №14).  
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№ Действие Результат 

21 

Составление эпюры осевого напряжения: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “LS,”, “1” > Apply >  

“By sequence num”, “LS,”, “4” > OK > Close 

 

22 

Прорисовка эпюры осевого напряжения: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res > 

LabI установить “LS1” 

LabJ установить “LS4” 

> OK  

Получаем тот же результат, что и на рис. 1в. (только числа, выделенные на рис. 1в. 

синим цветом). 

 

23 

Составление эпюры линейной осевой деформации: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “LEPEL,”, “1” > Apply >  

“By sequence num”, “LEPEL,”, “4” > OK > Close  

 

24 

Прорисовка эпюры линейной осевой деформации: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res > 

LabI установить “LEPE1” 

LabJ установить “LEPE4” 

> OK  

Получаем тот же результат, что и на рис. 1г. (только числа, выделенные на рис. 1г. 

синим цветом). 
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№ Действие Результат 

25 

Положительным в данной задаче считается перемещение ВЛЕВО, значит выводить 

результаты w следует в локальной системе координат №11. Укажем это: 

M_M > General Postproc > Options for Outp > 

[RSYS] установить “Local system” 

Local system reference no. пишем 11 

> OK  

 

 

Осевые перемещения (рис.1д.) в можно получить только дискретно, в узлах модели. Просмотреть результат можно тремя способами: 

а) Цветовая диаграмма (между узлами решение линейно интерполируется); 

б) Таблица перемещений в узлах; 

в) Эпюра (линейная интерполяция). 

Последнее – наиболее наглядно, но и наиболее трудоёмко. Просмотрим перемещения всеми тремя способами. 

26 

Осевые перемещения сечений стержня (цветовая шкала): 

M_M > General Postproc > Plot Results > Contour Plot > Nodal 

Solu > Nodal Solution > DOF Solution > X-Component of 

displacement > OK 

Цифры 1…4 есть номера узлов конечноэлементной модели (см. действие №14). 

Видно, что в узле 2 перемещение равно минимуму (по цветовой шкале это 0), в узле 

1 перемещение максимально (по цветовой шкале это 2) и от узла 1 до узла 3 так 

максимальным и остаётся (весь средний участок красного цвета). От узла 3 к узлу 4 

перемещение уменьшается, но не до нуля, а до зёлёного цвета (это от 0,8 до 1,2 по 

цветовой шкале).  

Пожалуй, это вся информация, которую можно извлечь из рисунка. 
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№ Действие Результат 

27 

Осевые перемещения сечений стержня (таблица): 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > X-Component of displacement 

> OK 

Получаем окно “PRNSOL Command” с табличкой, где NODE – номер узла 

конечноэлементной модели, а UX – его перемещение по горизонтали. Для того, 

чтобы вспомнить, где какой узел, выбираем: 

U_M > Plot > Nodes 
 

28 

Осевые перемещения сечений стержня (подготовка эпюры): 

Создаём массив-таблицу с названием, например, wtable : 

U_M > Parameters > Array Parameters > Define/Edit > Add >  

Par=”wtable” 

Type=”Table” 

I,J,K = 4,2,1 

> OK > Edit > 

Нумеруем столбец и строки массива. 

Заполняем массив вручную. 

Первый столбец – координаты узлов по возрастанию, то есть координаты узлов 2, 1, 

3, 4. Расстояния между соседними узлами по l то есть по 1. Причём, для того, чтобы 

эпюра изображалась справа налево, как на рис. 1д, координаты узлов указываем в 

глобальной системе координат в порядке возрастания. 

Второй столбец - перемещения UX узлов (см. действие №27). 

> File > Apply/Quit > Close 
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№ Действие Результат 

29 

Осевые перемещения сечений стержня (прорисовка эпюры): 

Параметры, необходимые для построения эпюры: по горизонтальной оси будет 

откладываться первый столбец массива, по оси ординат – второй столбец массива. 

U_M > Parameters > Scalar Parameters… > 

XN=1 > Accept > YN=2 > Accept > Close 

Сетка будет на обеих осях эпюры: 

U_M > PlotCtrls > Style > Graphs > Modify Grid > 

[/GRID] установить “X and Y lines”  

> OK 

Горизонтальную ось подписываем “L”, вертикальную ось подписываем “w”, 

интервал по горизонтальной оси устанавливаем от левого конца стержня до правого 

(0…L), а интервал по вертикальной оси таким, чтобы поместилась эпюра (-0,5…0): 

U_M > PlotCtrls > Style > Graphs > Modify Axes > 

 [/AXLAB] X-axis label пишем L  

 [/AXLAB] Y-axis label пишем w  

[/XRANGE] установить “Specified range”  

XMIN,XMAX установить “-3*L” и “0” 

 [/YRANGE] установить “Specified range”  

YMIN,YMAX установить “0” и “2*F*L/E/A” 

> OK 

Прорисовываем эпюру: 

U_M > Plot > Array Parameters  

ParX установить “wtable(1,XN)”  

ParY установить “wtable(1,YN)”  

> OK 
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№ Действие Результат 

30 

Потенциальная энергия упругой деформации U: 

M_M > General Postproc > List Results > Element Solution > 

Energy > Strain energy > OK 

Получаем список «Элемент-энергия». Суммируем энергию: 

2

5
5,25,002 U  

Получаем тот же результат, что и на рис. 1е. (только коэффициент перед формулой на 

рис. 1е.). 
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются файлы с 

расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, “.mntr”,  “.rst” и 

”.stat”. 

Интерес представляют “.db” (файл модели) и “.rst” (файл результатов расчёта), 

остальные файлы промежуточные, их можно удалить. 

 

 

 

 

 


